Start a new topic

ost-sdk-ruby is missing rack gem dependency

Looks like ost-sdk-ruby uses the rack gem, but does not specify it in the gemspec.


1 person has this problem

This issue was resolved by @Jason . There was a missing step in the documentation to install rack.


The solution is to issue the following command

sudo gem install rack


PS:  to use the gem ‘rack’ - ruby version 2.2.x is required

https://github.com/OpenSTFoundation/ost-sdk-ruby/issues/5

Well, that's not a missing step. That's a workaround. Solution is for ost-sdk-ruby to specify the dependency in the gemspec.

Login to post a comment