Start a new topic

Bug: "Error: transaction underpriced" when minting

I hit an issue when attempting to mint branded tokens.  After confirming the minting operation on OST I submit the minting transaction in Metamask, it failed without showing a warning and sent me back to the minting screen on OST.  The error shown in Metamask is "Error: transaction underpriced".  I retried the operation multiple times with the same result.

Also, I think that if there is a failure after confirming a minting order in OST, that error should be caught and the user should be notified. 


Message from Metamask:

Error: [ethjs-rpc] rpc error with payload {





Error: transaction underpriced

Hi Tyler!

Have you tried adjusting the Gas Limit and Gas Price on Metamask itself? 

I have tried to replicate the issue with default parameters (GWEI - 1; Gas Limit - 55938), but the transaction was signed successfully and staking & minting process was initiated. 

Hi Ignas,

I used the same settings that I always have, the defaults for Metamask.  I tried minting 6 times over the course of about 10 minutes (1526307716079 to 1524424724328), and each transaction failed with this error.  I came back a few hours after posting this bug and the minting processed fine using the same settings.  I considered adjusting the values in Metamask itself, but decided it was more valuable (test-wise) to see if the issue resolved itself.  If I hit it again I will try changing things. 

Side note: If changing Metamask values is something to be expected of users than it really should be explained in the UI.  ie.  If the tx fails show an alert recognizing the failure and suggesting to increase the gas limit/price.

Thanks for looking into it. :) 

It  must have been an issue related Ropsten network (this is a test network, so some issues are to be expected).

As for adjusting the values - default values should work - I just wanted to check if you have edited them.

Thanks for the feedback.

I tend to agree, but I have to caution that must is a dangerous word to use regarding testing... no software is perfect and errors can come from many unexpected places.  Waiving off an error for being 'on the test net' reduces the value of other testing being done.  I imagine this error would be very hard (or impossible) to debug since nothing went through to check the logs for, but that doesn't mean assumptions are ok.

Sorry for being finicky, I know you have no ill intentions, but I was a test lead for a few years and language in bugs can be very important! :)

1 person likes this

I have not waived the issue - it has been reported to the team to investigate. Apologies for the confusing language.

1 person likes this
Login to post a comment