Start a new topic

Bugs/issues with list endpoints in v1 API?

I have been having a few issues with the list endpoints with v1. I was wondering if it was just me, or has anyone else had similar issues?


I'll post all the issues I have come across so far:


Users

https://help.ost.com/support/discussions/topics/35000005451(if you pass names to the optional filter name, it is ignored)


Actions

Listing actions has some unexpected (read: not intuitive to me) behaviour when requesting a list that passes the optional filter of arbitrary_commission=true - this will also return user to company, and company to user actions. I'd say this is unexpected because U2C or C2U actions do not have a commission attribute - and even if they do but are simply not visible to us, they should most definitely be set to false.


Transactions

Listing transactions appears to be a bit hit and miss. majick777 noticed that when setting the limit to anything more than the total amount or transactions seems to cause a timeout.


I have also noticed that if I set the limit to 1, and page_no to 1 (with default sorting) the transaction is returned quick. If I set the order to ascending (to get the oldest transaction) it either times out, or takes just under a minute to get the single transaction.


Transfers

When I execute this with no options (i.e. with default options), it doesn't return anything and seems to timeout.



I'd love to know if anyone else is having any issues similar to these.


1 person has this problem
1 Comment

Same problem with the timeout when limit > total available actions.

Login to post a comment